Bonjour

Modérateurs : graffiop, jmdouin, agoncal, mlebihan

nathieb
Messages : 135
Inscription : 07 nov. 2006 18:08

Bonjour

Message par nathieb » 13 oct. 2007 22:19

Voila, j'ai fait une partie du développement mais j'ai une erreur java
au moment du test

Je suis sur debian Etch jdk1.5 ant 1.6.5.
Par ailleurs sur mon portable j'ai une erreur ant grave.

Buildfile: build.xml

yaps-prepare:
[echo] Setup the Yaps environment

yaps-compile:
[echo] Compile the YAPS classes
[echo] Compile the YAPS test classes

yaps-mark:
[echo] Marks the application
[java] Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
[java] at java.lang.ClassLoader.defineClass1(Native Method)
[java] at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
[java] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
[java] at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
[java] at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
[java] at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
[java] at java.security.AccessController.doPrivileged(Native Method)
[java] at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
[java] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
[java] at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
[java] Java Result: 1

BUILD SUCCESSFUL
Total time: 2 seconds

dois je changer mes versions.

Je perds beaucoups de temps

olivier

ellouze
Messages : 123
Inscription : 12 oct. 2007 22:27
Localisation : Paris
Contact :

Message par ellouze » 13 oct. 2007 22:45

Je te conseille d'utiliser jdk1.6. t'as tout ce qu'il te faut à partir de ce lien pour déployer ton environnement: http://iagl.free.fr/logiciel.html.

Bon courage.

Mohamed :P

nathieb
Messages : 135
Inscription : 07 nov. 2006 18:08

Je confirme

Message par nathieb » 14 oct. 2007 21:31

Bonjour,

Ok après install debian Etch jdk 1.6 + junit 4.4 tout est en ordre

merci

olivier

Répondre