TP10-pr

Modérateurs : graffion, jmdouin, agoncal, mlebihan

sophie2017
Messages : 24
Inscription : 26 nov. 2017 23:54

TP10-pr

Message par sophie2017 » 17 déc. 2017 16:12

Bonjour,

J'ai lancé ant yaps-test et ant yaps-mark , tous les tests passent avec aucune erreur ni de failure ,
mais sur chaque page du site petstore, j'ai l'erreur suivante:
Connection refused to host: 192.168.137.1; nested exception is: java.net.ConnectException: Connection refused: connect.

Du coup j'ai remarqué qu'il y a des exceptions sur la console de RMI :

Code : Tout sélectionner

......
dÚc. 17, 2017 2:52:52 PM sun.rmi.server.UnicastServerRef logCall
PLUS PR╔CIS: RMI TCP Connection(13)-192.168.137.1: [192.168.137.1: sun.rmi.registry.RegistryImpl[0:0:0, 0]: void unbind(java.lang.String)]
dÚc. 17, 2017 2:52:52 PM sun.rmi.server.UnicastServerRef logCall
PLUS PR╔CIS: RMI TCP Connection(14)-127.0.0.1: [127.0.0.1: sun.rmi.registry.RegistryImpl[0:0:0, 0]: java.rmi.Remote lookup(java.lang.String)]
dÚc. 17, 2017 2:52:52 PM sun.rmi.server.UnicastServerRef logCallException
PR╔CIS: RMI TCP Connection(14)-127.0.0.1: [127.0.0.1] exception:
java.rmi.NotBoundException: CustomerService
        at sun.rmi.registry.RegistryImpl.lookup(RegistryImpl.java:166)
        at sun.rmi.registry.RegistryImpl_Skel.dispatch(Unknown Source)
        at sun.rmi.server.UnicastServerRef.oldDispatch(UnicastServerRef.java:411)
        at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:272)
        at sun.rmi.transport.Transport$1.run(Transport.java:200)
        at sun.rmi.transport.Transport$1.run(Transport.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.rmi.transport.Transport.serviceCall(Transport.java:196)
        at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:568)
        at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:826)
        at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.lambda$run$0(TCPTransport.java:683)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:682)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
.....
 
Est ce que vous savez comment résoudre ce problème?
Merci

sophie2017
Messages : 24
Inscription : 26 nov. 2017 23:54

Re: TP10-pr

Message par sophie2017 » 17 déc. 2017 16:34

C'est bon, j'ai résolu le problème , il y avait une petite erreur dans le fichier startServer.bat, maintenant tout fonctionne bien

Code : Tout sélectionner

@echo off

set JAVA="%JAVA_HOME%\bin\java"
set RMIREGISTRY="%JAVA_HOME%\bin\rmiregistry"

set DEPLOY_DIR=D:\Java Cnam\GLG203\monTP10\Yaps\build
set LIB_DIR=D:\Java Cnam\GLG203\monTP10\lib

set XML_JAR=%LIB_DIR%\dom4j.jar;%LIB_DIR%\jaxen.jar

set CLASSPATH="%DEPLOY_DIR%\server.jar;%DEPLOY_DIR%\common.jar;%MYSQL_HOME%\lib\mysql-connector-java-5.1.21-bin.jar;%XML_JAR%"

start %RMIREGISTRY%

%JAVA% -Djava.rmi.server.logCalls=true -cp %CLASSPATH%  -Djava.util.logging.config.file=mylogging.properties com.yaps.petstore.server.RegisterServices

pause


Merci

saulnierJp
Messages : 51
Inscription : 27 déc. 2016 13:06

Re: TP10-pr

Message par saulnierJp » 19 déc. 2017 22:02

Bonjour Sophie,

Quelle était l'erreur du fichier bat?

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité