TP11 - failed to load ApplicationContext

Modérateurs : graffiop, jmdouin, agoncal, mlebihan

kagans_a
Messages : 18
Inscription : 20 oct. 2019 23:42

TP11 - failed to load ApplicationContext

Message par kagans_a » 13 janv. 2020 0:13

Bonjour,

Les test de com.yaps.petstore.domain.service échouent avec une exception failed to load ApplicationContext.

Plus précisément:

J'ai téléchargé les ressources fournis de TP11 et TPBB2, j'ai initialisé et peuplé la BD et j'ai implémenté la class src/main/java/com/yaps/petstore/domain/service/ShoppingCartServiceImpl.java

Avant d'implementer le reste, j'ai voulu tester la class implémentée.

J'ai lancé les deux serveurs et j'ai testé les services.
1. Catalog Service passe les testes.
2. Les trois autres (CreditCardServiceTest, OrderServiceTest et ShoppingCardTest) échouent avec l'exception "failed to load ApplicationContext".
Les sources de CreditCard et Order étant données, leur tests devraient passer?

Quand je lance les deux application sur le web, BarkBank affiche une page correctement.
TP11 (http://localhost:8080/petstore/), affiche une page blanche. L'application se lance mais affiche page vide (sans photos, sans la nav bar, juste page blanche).

Le code source affiche un html vide:
<!DOCTYPE HTML>
<html>
<head>

Quel peut être le problème?

En vous remerciant,

Asya

kagans_a
Messages : 18
Inscription : 20 oct. 2019 23:42

Re: TP11 - failed to load ApplicationContext

Message par kagans_a » 13 janv. 2020 0:45

P.S
Pour obtenir l'affiche de la page d'accueil, il faut implementer les classes html manquantes.

En revanche, je ne comprends pas pourquoi les testes de CreditCardService et OrderService échouent.

En vous remerciant, Asya

harrak_z
Messages : 66
Inscription : 19 oct. 2019 20:15

Re: TP11 - failed to load ApplicationContext

Message par harrak_z » 15 janv. 2020 1:13

Premiere étape implementer la classe ShoppingCartServiceImp
Ensuite, relancer les tests unitaires .. ..

Répondre