TP06 voir le formulaire

Modérateurs : graffion, jmdouin, agoncal, mlebihan

Ruddy Reisberg
Messages : 41
Inscription : 01 nov. 2016 16:13

TP06 voir le formulaire

Message par Ruddy Reisberg » 22 nov. 2017 0:33

Bonjour,

Comment faites vous pour voir le formulaire sur le navigateur?
Tomcat tourne mais à chaque fois que je fais run on server depuis eclipse, il tombe toujours sur une page 404.

1° Quelle est la bonne url à entrer?
2° Quelle opération me faut-il faire pour régler le problème?

Merci par avance

PhilG
Messages : 21
Inscription : 12 nov. 2017 10:25

Re: TP06 voir le formulaire

Message par PhilG » 22 nov. 2017 8:21

En ce qui me concerne, je n'ai pas fait le projet en "Web Project Dynamique" (Ou un truc qui y ressemble).

Je n'ai pas voulu prendre de risque.

Les étapes suivantes devraient te permettre d'y arriver.

1) ant yaps-clean : Cela permet de nettoyer les classes. Dans mon cas, j'avais un moment ajouté des classes que j'ai supprimé. J'ai eu la mauvaise surprise de les voir encore.
2) ant yaps-build, qui construit le projet.
3) Nettoyer webapps du Tomcat (petstore dossier et war).
4) Démarrer RMI
5)Démarrer Tomcat (start.bat sous Windows)
6)Taper l'URL localhost:8080/petstore

On arrive sous la page "index" de l'application, en l'occurrence le formulaire.

Cordialement.
Dernière édition par PhilG le 22 nov. 2017 14:32, édité 1 fois.

Ruddy Reisberg
Messages : 41
Inscription : 01 nov. 2016 16:13

Re: TP06 voir le formulaire

Message par Ruddy Reisberg » 22 nov. 2017 14:25

Bonjour,

Merci pour ta réponse
Ca ne marche toujours pas....
Vous avez crée les classes WebConverstion, Web form etc... qui se trouvent dans la classe Web Test?
Moi oui mais je ne les ai pas du tout implementées, je les ai juste réeglées pour ne pas quelle bloquent les tests.
Peut etre que c'est ac qui bloque...

Pour moi:
J'ai deux faillures sur WebTest :
junit.framework.AssertionFailedError: A dummy HTML page has been found


et 1 erreur sur createCustomerServletTest (null pointer exception)

Si ces infos peuvent aider...

PhilG
Messages : 21
Inscription : 12 nov. 2017 10:25

Re: TP06 voir le formulaire

Message par PhilG » 22 nov. 2017 14:30

NullPointerException, le message est clair.

Mais les causes sont nombreuses.

Récupères-tu les classes par RMI?
Les sous classes (genre Address) sont-elles instanciées?

Les logs Tomcat peuvent fournir une réponse.

Cordialement.

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité