Petstore services couldn't be registered

Modérateurs : graffion, jmdouin, agoncal, mlebihan

PhilG
Messages : 24
Inscription : 12 nov. 2017 10:25

Re: Petstore services couldn't be registered

Message par PhilG » 13 nov. 2017 8:22

J'ai aussi modifié le script (http://deptmedia.cnam.fr/phpBB3/viewtop ... 5a466bf121).

En fait, j'ai lancé l'annuaire RMI à l’extérieur, avant.

Malheureusement, je suis arrivé à une exception et je n'ai pas trouvé de solutions, pour l'instant.

Tu peux avoir l'exception dans le fichier log.

Cordialement.

PhilG
Messages : 24
Inscription : 12 nov. 2017 10:25

Re: Petstore services couldn't be registered

Message par PhilG » 14 nov. 2017 7:35

Essaye de lancer séparément le registre RMI et le server.

Cordialement.

PhilG
Messages : 24
Inscription : 12 nov. 2017 10:25

Re: Petstore services couldn't be registered

Message par PhilG » 15 nov. 2017 8:18

En fait, tous les tests tournes chez moi.

J'ai juste eu un contre-temps à cause des tests propres à RMI.

Le mieux est donc de faire tourner les tests non-RMI.

Je pense que ton problème viens d'un test fonctionnel.

Une ligne, à mon avis, argumente dans mon sens:

Code : Tout sélectionner

Exception levée: com.yaps.petstore.common.exception.CheckException


Cordialement.

Ruddy Reisberg
Messages : 53
Inscription : 01 nov. 2016 16:13

Re: Petstore services couldn't be registered

Message par Ruddy Reisberg » 15 nov. 2017 15:46

Bonjour,

J'ai la même erreur mais elle ne m'étonne pas car, dans le test le unitcost vaut 0, tandis que le checkData de Item lève une exception si le unitCost vaut 0...

Répondre