GLG203 : TP00 - Problème avec cible yaps-compile [RESOLU]

Modérateurs : graffion, jmdouin, agoncal, mlebihan

POUZOL
Messages : 16
Inscription : 30 sept. 2015 16:37

GLG203 : TP00 - Problème avec cible yaps-compile [RESOLU]

Message par POUZOL » 03 oct. 2016 21:06

Bonjour,

En lançant la commande yaps-test, je récupère le message suivant dans la section (target) yaps-compile:
[echo] Compile the YAPS classes
[javac] D:\...\TP00.ess\Yaps\build.xml:90: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last;
set to false for repeatable builds

BUILD FAILED

J'ai évidemment cherché dans Google la solution. La première proposée dans http://stackoverflow.com/questions/5103 ... as-not-set
est
Simply set includeantruntime="false":

<javac includeantruntime="false" ...>...</javac>
If you have to use the javac-task multiple times you might want to consider using PreSetDef to define your own javac-task that always sets includeantruntime="false".
Doit on modifier build.xml pour régler ce problème ou y a-t-il une autre façon de faire ?

Bruno

POUZOL
Messages : 16
Inscription : 30 sept. 2015 16:37

Re: GLG203 : TP00 - Problème avec cible yaps-compile

Message par POUZOL » 03 oct. 2016 21:31

Bonjour,

j'ai appliqué la solution. Elle marche.
Erreur suivante :
class not found : javac1.8

La version de ant proposée, 1.8.4 n'est pas compatible avec les autres versions des logiciels installés.
En installant la plus récente, 1.9.7, ça marche enfin.

Bruno

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité